Dublin Core 메타데이터 요소 집합 Version 1.1 : 관련 설명
(Dublin Core Metadata Element Set, Version 1.1 : Reference Description)

 

 

문서의 발행일 :

1999-07-02

식별자 :

http://dublincore.org/documents/dces/

이전 버전의

식별자 :

 

http://dublincore.org/resources/translations/

대체 자원 :

해당사항 없음

최신 버전 :

http://dublincore.org/documents/dces/

번역본들 :

http://dublincore.org/resources/translations/ - dces1-1

문서의 지위 :

이 문서는 Dublin Core Metadata Initiative Recommendation (권고문)이다. 그러므로 이 문서에 나타나 있는 세부적인  사항들은 모두 신뢰할 만한 것으로서, Dublin Core를 사용하는 집단이 이를 채택하도록 권장되고 있다.

문서에 대한

설명 :

이 문서는 Dublin Core 메타데이터 요소 집합(버전 1.1)에 대한 설명을 담은 것으로서, 버전 1.0 을 대체하는 것이다. 워크샵이나 각종 보고서, 작업 그룹의 문서, 프로젝트, 그리고 메타데이터 요소와 관련한 새로운 발전 상황 등에 대하여 더욱 자세한 정보를 얻고자 한다면, Dublin Core의 홈페이지(http://dublincore.org/) 를 참조하라.

 

 

머  리  말

이 문서는 Dublin Core(이하 DC)의 메타데이터 요소들에 대한 최신의 정의(definition)를 담고 있다. 이러한 새로운 정의는 공식적으로 버전 1.1로 일컬어진다.

이 문서에서는, 각각의 메타데이터 요소에 대해서 공식적인 표준을 사용하여 정의를 내리고 있는데, 이렇게 형식을 갖춤으로써, 다른 메타데이터 커뮤니티와의 일관성을 유지할 수 있고 DC 메타데이터 요소에 대한 규정에 명확성을 기할 수 있으며 또한 적용범위 및 정의들 간의 내부적 일관성을 강화할 수 있다.

각각의 DC 요소는 데이터 요소의 기술을 위한 표준인 ISO/IEC 11179[ISO11179] 에서 가지고 온 10가지 속성(1 set)을 사용하여 정의된다. 이는 다음과 같다 :

● Name – 데이터 요소에 주어진 요소명(label)
● Identifier – 데이터 요소에 할당된 고유한 식별자
● Version – 데이터 요소의 버전
● Registration Authority – 데이터 요소의 등록 권한을 부여 받은 개체
● Language – 데이터 요소의 상세화에 사용된 언어
● Definition – 데이터 요소의 개념과 중요 특성을 명확하게 나타낼 수 있는 설명
● Obligation – 그 데이터 요소가 항상 있어야 하는 것인지 또는 선택적인 것인지를 가리킴(value를 가짐)
● Datatype – 데이터 요소의 값을 표현하는 데이터의 유형
● Maximum Occurrence – 기본적으로 데이터 요소의 반복사용이 가능한데, 이에 대하여 어떠한 제한점이 있을 때 이를 표시함
● Comment – 데이터 요소의 적용과 관련한 기타 설명 

다행히도, 위의 10가지 속성 중 6가지는 모든 DC 요소에 공통된다. 다음은 이 6가지 속성과 각각의 속성에 해당하는 값이다.  

Version :

1.1

Registration Authority :

Dublin Core Metadata Initiative

Language :

en

Obligation :

Optional

Datatype :

Character String

Maximum Occurrence :

Unlimited

 그러므로 위의 6가지 속성들을 아래의 정의에서 다시 반복해서 쓸 필요는 없겠지만, 위의 속성 값들이 각 요소에 대한 공식적인 정의의 일부분이라는 것은 기억할 필요가 있을 것이다. 

여기에서 제시된 각 DC 요소에 대한 정의는, 그 요소의 개념적 형식과 표현 형식, 양자 모두를 포괄한다. 즉, 위의 10가지 속성 중 Definition 속성이 의미론적 개념을 포착한다면, Datatype 과 Comment 속성은 데이터의 표시 및 표현(representation) 에 초점을 맞춘다고 할 수 있겠다. 

각각의 DC 요소에 대한 정의는 ‘자원(resource)’이라는 말과 관련되어 나타나는데, ‘자원’은 DC 요소를 통해 기술되는 대상이기 때문이다. ‘자원’이란 [RFC2396]에 설명된 바에 의하면 “identity를 지닌 모든 것”이다. 이를 DC 메타데이터와 관련시켜서 구체적으로 생각해보면, ‘자원’이란 통상적으로 정보나 서비스 자원을 의미하는 것이나, 이러한 의미는 보다 더 넓게 적용될 수도 있을 것이다.

 DC 메타데이터 요소에 대한 규정

요소(1) : 표제 (Title)

Name :

Title

Identifier :

Title

Definition :

그 자원에 부여된 제목

Comment :

대체로 표제는 그 자원을 공식적으로 지칭하는 이름일 것임.

요소(2) : 제작자 (Creator)

Name :

Creator

Identifier :

Creator

Definition :

자원의 내용에 주된 책임을 가진 개체

Comment :

제작자의 예로서는, 사람이나 기관, 또는 공공사업을 들 수 있음.

제작자를 표시하기 위해서는 대체로 제작자의 이름이 사용됨.

요소(3) : 주제 (Subject) 

Name :

Subject

Identifier :

Subject

Definition :

자원의 내용이 지닌 주제(topic)

Comment :

대체로, 주제는 자원의 주제를 표현하는 키워드나 구절, 또는 분류 코드로 나타내어진다.

또한 통제 어휘나 공식적인 분류 스킴에 의한 값을 사용하는 것이 최상의 방법으로서 권장되고 있다.

요소(4) : 설명 (Description)

Name :

Description

Identifier :

Description

Definition :

자원의 내용에 대한 설명

Comment :

설명에는 초록이나 내용목차, 내용에 대한 시각적인(graphical) 표현, 또는 자유로운 텍스트 기술 등이 포함되나, 이것들로만 국한되는 것은 아님.

요소(5) : 발행처 (Publisher)

Name :

Publisher

Identifier :

Publisher

Definition :

자원을 현재의 형태로 이용가능하게 만든 실체

Comment :

발행처의 예로서는, 사람, 기관, 또는 공공사업 등이 포함된다.

대체로 발행처의 이름이 발행처를 지시하는데 사용됨.

요소(6) : 기타 제작자 (Contributor)

Name :

Contributor

Identifier :

Contributor

Definition :

제작자 요소에 명시된 개체 이외에, 자원의 내용에 기여한 책임이 있는 기타 개체

Comment :

기타 제작자의 예로서는, 사람, 기관, 또는 공공사업이 포함된다.

대체로, 기타 제작자의 이름이 기타 제작자를 지시하는데 사용됨.

요소(7) : 날짜 (Date)

Name :

Date

Identifier :

Date

Definition :

자원의 존재 기간 동안 어떠한 사건이 발생한 날짜.

Comment :

대체로, 날짜란 자원의 제작일 또는 자원이 현재의 형태로 이용가능하게 된 시점과 관련된다. 날짜 값의 인코딩을 위한 최선책으로서, ISO 8601[W3CDTF]의 YYYY-MM-DD 형식을 취할 것이 권장됨.

요소(8) : 자료 유형 (Type)

Name :

Type

Identifier :

Type

Definition :

자원 내용의 성격 또는 장르

Comment :

자료 유형은 내용의 일반적인 범주, 기능, 장르, 또는 집성 수준을 표현하는 말이다.

통제 어휘의 사용이 권장되고 있음. (예를 들면, DC의 자료 유형에 관한 작업 초안 리스트[DCT1]).

자원의 물리적 또는 디지털 표현 형식을 설명하기 위해서는 형식(Format) 요소를 사용하라.

요소(9) : 형식 (Format)

Name :

Format

Identifier :

Format

Definition :

자원의 물리적 표현형식 및 디지털 표현형식

Comment :

대체로, 형식은 자원의 매체 유형이나 특질을 포함한다. 형식은 자원을 보여주거나 실행시키는데 필요한 소프트웨어나 하드웨어, 또는 기타 장치를 결정하기 위해서 사용될 수 있다. 특질의 예로는, 크기(용량)나 기간을 들 수 있다.

이것 또한 통제 어휘의 사용이 권장됨. (예를 들면, 컴퓨터 미디어 형식을 정의하고 있는 Internet Media Types[MIME]).

요소(10) : 식별자 (Identifier)

Name :

Identifier

Identifier :

Identifier

Definition :

자원을 가리키는 지시자. 주어진 형태만으로는 그 의미를 알 수 없음.

Comment :

자원의 식별을 가장 잘 수행하기 위해서는 공인된 식별체계를 따르는 문자/숫자열을 사용할 것이 권장된다.

공인된 식별체계의 예로는, URI, URL, DOI, ISBN 등을 들 수 있다.

요소(11) : 출처 (Source)

Name :

Source

Identifier :

Source

Definition :

현재 자원의 출처가 되는 원정보자원으로의 참조

Comment :

현재 자원이 어떠한 원정보자원으로부터 전체적으로 또는 부분적으로 파생된 경우에 필요한 요소이다.

원정보에 대한 참조에서 공인된 식별체계를 따르는 문자/숫자열을 사용할 것이 권장됨.

요소(12) : 언어 (Language)

Name :

Language

Identifier :

Language

Definition :

자원의 지적인 내용을 기술하고 있는 언어

Comment :

언어를 표시하는 최선의 방법으로서는, 2문자의 약어로 된 언어코드(ISO 639[ISO639]에서 옴)를 포함하는 RFC 1766 [RFC1766]을 따를 것이 권장되고 있다.

또한 ISO 3166[ISO3166]에서 취한 2문자의 국가코드를 선택적으로 적용할 수 있다.

예를 들어, ‘en’은 영어를, 또 ‘fr’은 프랑스어를 나타내며, ‘en-uk’는 영국에서 사용되는 영어를 의미한다.

요소(13) : 관련자료 (Relation)

 

Name :

Relation

Identifier :

Relation

Definition :

관련 자원들로의 참조

Comment :

관련 자료에의 참조를 표현함에 있어서, 공식적인 식별체계에 따라 만들어지는 문자/숫자를 사용할 것이 권장됨.

요소(14) : 내용범위 (Coverage) 

Name :

Coverage

Identifier :

Coverage

Definition :

자원의 내용 범위

Comment :

내용범위에는 대체로 공간적 위치(장소의 명칭, 지리적 위·경도)나 시간적(시대적) 범위(시대명, 날짜, 기간 등), 관할권(행정구역의 이름) 등이 포함된다.

내용범위를 기술할 때 통제 어휘를 사용할 것이 권장된다.(예를 들면, 지리적 명칭의 시소러스[TGN], 지리적 좌표나 시간의 범위와 같은 숫자보다는 공식적 지명/기간명 등)

요소(15) : 이용조건 (Rights)

Name :

Rights

Identifier :

Rights

Definition :

그 자원에 대해서 갖고 있는 권리에 관한 정보

Comment :

대체로 이용조건 요소는 자원에 대한 저작권 관리 및 이용권리에 관한 설명이나 그러한 정보를 제공하는 서비스로의 연결을 포함한다. 이용조건 정보는 지적재산권(IPR)이나 저작권 등의 개념을 포함한다.

만약 이용조건 요소에 대한 기술이 없다고 해서 그 자원을 마음대로 사용해도 되는 것으로 함부로 간주할 수는 없다.

참고 자료

[DCT1] Type Vocabulary.
<
http://dublincore.org/documents/dcmi-type-vocabulary/>

[ISO11179] ISO 11179 - Specification and Standardization of Data Elements, Parts 1-6.
<ftp://sdct-sunsrv1.ncsl.nist.gov/x3l8/11179/>

[ISO639] ISO 639 - Codes for the representation of names of languages.
<http://www.oasis-open.org/cover/iso639a.html>

[ISO3166] ISO 3166 - Codes for the representation of names of countries.
<http://www.oasis-open.org/cover/country3166.html>

[MIME] Internet Media Types.
<http://www.isi.edu/in-notes/iana/assignments/media-types/media-types

[RFC1766] Tags for the Identification of Languages, Internet RFC 1766.
<
http://www.ietf.org/rfc/rfc1766.txt>

[RFC2396] Uniform Resource Identifiers (URI): Generic Syntax, Internet RFC 2396.
<
http://www.ietf.org/rfc/rfc2396.txt>

[RFC2413] Dublin Core Metadata for Resource Discovery. Internet RFC 2413.
<
http://www.ietf.org/rfc/rfc2413.txt>

[TGN] Getty Thesaurus of Geographic Names.
<http://shiva.pub.getty.edu/tgn_browser/>

[W3CDTF] Date and Time Formats, W3C Note.
<http://www.w3.org/TR/NOTE-datetime>
 




Metadata associated with this resource: http://dublincore.org/index.shtml.rdf